Degraded apply experience

Incident Report for SEEK API

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 06:14 UTC

Update

We are continuing to investigate this issue.
Posted Jul 14, 2026 - 06:01 UTC

Investigating

We are seeing intermittent failures in the SEEK Optimised Apply flow. We are currently investigating the issue.
Posted Jul 14, 2026 - 06:00 UTC
This incident affected: SEEK Optimised Apply.