Major SEEK API Outage

Incident Report for SEEK API

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 02:02 UTC

Update

An internal network change has been identified as the root cause and a rollback is in progress.
Posted Mar 17, 2026 - 00:45 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 17, 2026 - 00:43 UTC

Investigating

We are currently investigating this issue.
Posted Mar 17, 2026 - 00:33 UTC
This incident affected: SEEK Job Posting, SEEK Optimised Apply, Talent Search Connect, Apply with SEEK, Ad Performance and Core platform (Auth, Events).