Ad Performance data delay

Incident Report for SEEK API

Resolved

This incident has been resolved.
Posted May 08, 2026 - 15:09 UTC

Identified

Ad Performance for last 24 hours may not be shown due to a delay in delivery of data
Posted May 07, 2026 - 00:21 UTC
This incident affected: Ad Performance.