Degraded candidate profile summaries view for hirers
Resolved
This incident has been resolved.
Posted Jun 30, 2026 - 03:38 UTC
Investigating
Hirers may not be able to view candidate profile summaries via the panels.
Posted Jun 30, 2026 - 03:26 UTC
This incident affected: Talent Search Connect.