System Degredation

Incident Report for SEEK API

Resolved

We identified an internal networking upgrade as the cause of the elevated errors. This has been resolved.
Posted Aug 21, 2026 - 01:58 UTC

Update

We are continuing to investigate this issue.
Posted Aug 21, 2026 - 01:57 UTC

Investigating

We are currently investigating this issue.
Posted Aug 21, 2026 - 01:53 UTC
This incident affected: Ad Performance, Apply with SEEK, Developer tools, SEEK Optimised Apply, SEEK Profiles, Selection Signals, Talent Search Connect, SEEK Job Posting (Ad Sync, Classic Job Posting, Enhanced Job Posting), and Core platform (Auth, Events).