SEEK API performance degraded

Incident Report for SEEK API

Resolved

This incident has been resolved.
Posted May 18, 2026 - 05:07 UTC

Update

This incident has been resolved.
Posted May 18, 2026 - 05:05 UTC

Investigating

We have noticed a performance degradation on the SEEK API overall. We are currently investigating.
Posted May 18, 2026 - 03:06 UTC
This incident affected: SEEK Job Posting, SEEK Optimised Apply, Talent Search Connect, Apply with SEEK, Ad Performance, Developer tools and Core platform (Auth, Events).