Apply with SEEK degredation

Incident Report for SEEK API

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 06:15 UTC

Investigating

We have noticed a performance degradation on the Apply with SEEK flow. We are currently investigating.
Posted Apr 21, 2026 - 06:00 UTC
This incident affected: Apply with SEEK.