Elevated API errors

Incident Report for SEEK API

Resolved

Resolved as a result of third party fixes being rolled out. All impacted services have been restored.
Posted Dec 10, 2025 - 05:58 UTC

Identified

We have identified an issue with an underlying third party service provider and are currently awaiting updates.
Posted Dec 10, 2025 - 04:33 UTC

Investigating

SEEK API is experiencing elevated errors starting from 1:12pm GTM+11.
Posted Dec 10, 2025 - 03:00 UTC
This incident affected: SEEK Job Posting, SEEK Optimised Apply, Talent Search Connect, and Apply with SEEK.