System degradation

Incident Report for SEEK API

Resolved

We identified an internal networking upgrade as the cause of the elevated errors. This has been resolved.
Posted Jun 19, 2026 - 01:35 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 19, 2026 - 01:27 UTC

Update

We are continuing to investigate this issue.
Posted Jun 19, 2026 - 00:52 UTC

Update

We are continuing to investigate this issue.
Posted Jun 19, 2026 - 00:52 UTC

Investigating

We have identified an networking issue, we are investigating and will provide updates soon
Posted Jun 19, 2026 - 00:43 UTC
This incident affected: Ad Performance, Apply with SEEK, Developer tools, SEEK Optimised Apply, Talent Search Connect and SEEK Job Posting (Classic Job Posting).