This change has been reverted and will be rescheduled for a future date.
Posted Jun 01, 2023 - 23:02 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 01, 2023 - 23:00 UTC
Scheduled
# What is the change?
On the 2nd of June at 9am AEST, the lifetime of SEEK API partner tokens (https://developer.seek.com/auth/partner-tokens) will be reduced from 24 hours to 30 minutes. Your hirers may be unable to post job ads and receive candidate applications if your SEEK integration does not comply with token expiry best practices after this date.
# Why is this happening?
This change is a routine security upgrade to safeguard both SEEK and our partners in the event of a compromised API credential.
# Action required from partners
No action is required if your software caches partner tokens based on the number of seconds specified in the `expires_in` of the partner token response.
If your software has hardcoded the token’s expiry or you are not currently caching partner tokens, you must update it to cache dynamically as described in our partner token documentation (https://developer.seek.com/auth/partner-tokens).